home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-python / numeric-23.7 / numeric-23.7.ebuild < prev    next >
Text File  |  2006-01-20  |  885b  |  36 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-23.7.ebuild,v 1.15 2005/08/22 22:34:17 lucass Exp $
  4.  
  5. inherit distutils eutils
  6.  
  7. MY_P=${P/n/N}
  8. S=${WORKDIR}/${MY_P}
  9.  
  10. DESCRIPTION="a fast, compact, multidimensional array language facility"
  11. HOMEPAGE="http://numeric.scipy.org/"
  12. SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
  13.  
  14. LICENSE="as-is"
  15. SLOT="0"
  16. KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 s390 sparc x86"
  17. IUSE=""
  18.  
  19. # 2.1 gave sandbox violations see #21
  20. DEPEND=">=dev-lang/python-2.2"
  21.  
  22. src_unpack() {
  23.     unpack ${A}
  24.     cd "${S}"
  25.     epatch "${FILESDIR}"/${P}.patch
  26. }
  27.  
  28. src_install() {
  29.     distutils_src_install
  30.     distutils_python_version
  31.  
  32.     #Numerical Tutorial is nice for testing and learning
  33.     insinto /usr/lib/python${PYVER}/site-packages/NumTut
  34.     doins Demo/NumTut/*
  35. }
  36.